Ubuntu 19.04: How to Install Adobe Acrobat Reader

Back  in the days when Adobe Acrobat Reader for Linux was supported and available on the main/extra repos, this command would have done the job

apt install adobereader-enu

As hinted in the previous comment, such install command had no longer produced the desired result as shown below

kimconnect@nuc:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.04
Release: 19.04
Codename: disco
kimconnect@nuc:~$ sudo apt install adobereader-enu
[sudo] password for kimconnect:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package adobereader-enu

Instructions to Install Acrobat Reader 9.5.5 on Ubuntu 19.04

Check for the latest versions of Acrobat here: 
ftp://ftp.adobe.com/pub/adobe/reader/unix

Acrobat 9.5.5 is the latest Linux version as of this writing:

cd ~/Downloads && wget -c ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
# Install
sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

There will be errors indicating that a direct dependency is missing. Install that

# Installing a dependency - expecting "missing dependencies" error
sudo apt install libgtk2.0-0:i386

# Run this command to fix any missing dependencies the previous install has missed
sudo apt install -f

Output:
kimconnect@nuc:~/Downloads$ sudo apt install libgtk2.0-0:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libgtk2.0-0:i386 : Depends: libgtk2.0-common:i386
Depends: libatk1.0-0:i386 (>= 1.32.0) but it is not going to be installed
Depends: libc6:i386 (>= 2.28) but it is not going to be installed
Depends: libcairo2:i386 (>= 1.6.4-6.1) but it is not going to be installed
Depends: libcups2:i386 (>= 1.6.2) but it is not going to be installed
Depends: libfontconfig1:i386 (>= 2.12.6) but it is not going to be installed
Depends: libgdk-pixbuf2.0-0:i386 (>= 2.22.0) but it is not going to be installed
Depends: libglib2.0-0:i386 (>= 2.41.1) but it is not going to be installed
Depends: libpango-1.0-0:i386 (>= 1.28.3) but it is not going to be installed
Depends: libpangocairo-1.0-0:i386 (>= 1.28.3) but it is not going to be installed
Depends: libpangoft2-1.0-0:i386 (>= 1.28.3) but it is not going to be installed
Depends: libx11-6:i386 (>= 2:1.4.99.1) but it is not going to be installed
Depends: libxcomposite1:i386 (>= 1:0.3-1) but it is not going to be installed
Depends: libxcursor1:i386 (> 1.1.2) but it is not going to be installed
Depends: libxdamage1:i386 (>= 1:1.1) but it is not going to be installed
Depends: libxext6:i386 but it is not going to be installed
Depends: libxfixes3:i386 but it is not going to be installed
Depends: libxi6:i386 but it is not going to be installed
Depends: libxinerama1:i386 but it is not going to be installed
Depends: libxrandr2:i386 (>= 2:1.5.0) but it is not going to be installed
Depends: libxrender1:i386 but it is not going to be installed
Recommends: libgail-common:i386 but it is not going to be installed
Recommends: libgtk2.0-bin:i386
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
# Retry the Install
sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb

# Set as default for pdf extensions
mimeopen -d *.pdf

This output shows that there are further missing dependencies


kimconnect@nuc:~/Downloads$ mimeopen -d *.pdf
Please choose a default application for files of type application/pdf

1) Document Viewer (org.gnome.Evince)
2) LibreOffice Draw (libreoffice-draw)
3) Adobe Reader 9 (AdobeReader)
4) Other...

use application #3
Opening "Consumer Report.pdf", "Python Tutorials.pdf" with Adobe Reader 9 (application/pdf)
/opt/Adobe/Reader9/Reader/intellinux/bin/acroread: error while loading shared libraries: libxml2.so.2: cannot open shared object file: No such file or directory

# Fix missing dependency named in previous error
sudo apt install libxml2:i386

# Retried and see more errors
Gtk-Message: 08:05:53.229: Failed to load module "atk-bridge"

(acroread:19368): Gtk-WARNING **: 08:05:53.247: Unable to locate theme engine in module_path: "adwaita",

(acroread:19368): Gtk-WARNING **: 08:05:53.247: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.250: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.250: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.251: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.251: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.251: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.252: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.252: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.252: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.253: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.253: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.253: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.253: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.253: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.254: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.254: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.254: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.254: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.254: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.255: Unable to locate theme engine in module_path: "pixmap",

(acroread:19368): Gtk-WARNING **: 08:05:53.256: Unable to locate theme engine in module_path: "adwaita",
Gtk-Message: 08:05:53.257: Failed to load module "canberra-gtk-module"
/opt/Adobe/Reader9/Reader/intellinux/bin/SynchronizerApp-binary: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory
/opt/Adobe/Reader9/Reader/intellinux/bin/SynchronizerApp-binary: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory
/opt/Adobe/Reader9/Reader/intellinux/bin/SynchronizerApp-binary: error while loading shared libraries: libidn.so.11: cannot open shared object file: No such file or directory

Fix the additional dependency errors:

sudo apt install libidn11:i386 libpangox-1.0:i386 libcanberra-gtk-module:i386 libgtk2.0-0:i386 libxml2:i386 libxslt1.1:i386 libstdc++6:i386 gtk2-engines-pixbuf:i386 libatk-adaptor:i386 libgail-common:i386 gnome-themes-extra:i386
Posted on Categories Linux

Leave a Reply

Your email address will not be published. Required fields are marked *