Installing Simple NFS GUI (for Ubuntu / Mint / Debian)

Overview:

Simple NFS GUI is a Linux application that automates the whole NFS share configuration process. In NFS server mode, the tool automatically sets up the /etc/exports configuration. Security is enforced via /etc/hosts.deny and /etc/hosts.allow. In NFS client mode, the application automatically creates a directory for the mount point by adding the NFS mount to the /etc/fstab file with the necessary users option as required for accessing by non-root users.

# Source: https://github.com/Philippe734/Simple.NFS.GUI

# Installation
sudo add-apt-repository ppa:gambas-team/gambas3 -y && sudo apt-get update
wget https://github.com/Philippe734/Simple.NFS.GUI/raw/master/Linux/1.0.16/simple-nfs-gui_1.0.16-0ubuntu1_all.deb -P ~ && sudo dpkg -i ~/simple-nfs-gui_1.0.16-0ubuntu1_all.deb
sudo apt-get install -fy && rm ~/simple-nfs-gui_1.0.16-0ubuntu1_all.deb && sudo -H Simple_NFS_GUI

# Run Application
sudo -H Simple_NFS_GUI
# Log of installation
kim@kim-linux:~$ sudo add-apt-repository ppa:gambas-team/gambas3 -y && sudo apt-get update && wget https://github.com/Philippe734/Simple.NFS.GUI/raw/master/Linux/1.0.16/simple-nfs-gui_1.0.16-0ubuntu1_all.deb -P ~ && sudo dpkg -i ~/simple-nfs-gui_1.0.16-0ubuntu1_all.deb && sudo apt-get install -fy && rm ~/simple-nfs-gui_1.0.16-0ubuntu1_all.deb && sudo -H Simple_NFS_GUI
You are about to add the following PPA:
 More info: https://launchpad.net/~gambas-team/+archive/ubuntu/gambas3
Executing: /tmp/apt-key-gpghome.jtw69cec1c/gpg.1.sh --keyserver hkps://keyserver.ubuntu.com:443 --recv-keys BEC4D34EA23B1DA104D3F98450B027516CAEE58D
gpg: key 50B027516CAEE58D: public key "Launchpad PPA for Gambas Ubuntu Maintainers" imported
gpg: Total number processed: 1
gpg:               imported: 1
Ign:1 http://packages.linuxmint.com ulyssa InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Get:3 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]      
Hit:4 http://archive.canonical.com/ubuntu focal InRelease                      
Hit:5 http://packages.linuxmint.com ulyssa Release                             
Get:6 https://packages.microsoft.com/repos/vscode stable InRelease [3,959 B]   
Hit:7 https://packages.microsoft.com/ubuntu/20.04/prod focal InRelease         
Get:8 https://packages.microsoft.com/repos/code stable InRelease [10.4 kB]     
Hit:9 http://dl.google.com/linux/earth/deb stable InRelease                    
Hit:10 http://archive.ubuntu.com/ubuntu focal InRelease                        
Get:12 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]       
Get:13 https://packages.microsoft.com/repos/vscode stable/main amd64 Packages [266 kB]
Get:14 https://packages.microsoft.com/repos/code stable/main arm64 Packages [52.6 kB]
Get:15 https://packages.microsoft.com/repos/code stable/main amd64 Packages [51.9 kB]
Get:16 https://packages.microsoft.com/repos/code stable/main armhf Packages [52.5 kB]
Get:17 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [949 kB]
Get:18 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]     
Get:19 http://archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [551 kB]
Get:20 http://security.ubuntu.com/ubuntu focal-security/main i386 Packages [297 kB]
Get:21 http://security.ubuntu.com/ubuntu focal-security/main Translation-en [178 kB]
Get:22 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [29.0 kB]
Get:23 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [483 kB]
Get:24 http://security.ubuntu.com/ubuntu focal-security/restricted Translation-en [69.2 kB]
Get:25 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [63.6 kB]
Get:26 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Get:27 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1,298 kB]
Get:28 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [283 kB]
Get:29 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [524 kB]
Get:30 http://archive.ubuntu.com/ubuntu focal-updates/universe i386 Packages [642 kB]
Get:31 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [867 kB]
Get:32 http://archive.ubuntu.com/ubuntu focal-updates/universe Translation-en [186 kB]
Get:33 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [363 kB]
Get:34 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata [19.3 kB]
Get:35 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [940 B]
Get:36 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [10.4 kB]
Get:37 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal InRelease [17.5 kB]
Hit:38 http://ppa.launchpad.net/gezakovacs/ppa/ubuntu focal InRelease          
Get:39 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 Packages [15.6 kB]
Get:40 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main i386 Packages [6,008 B]
Get:41 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main Translation-en [6,220 B]
Fetched 7,627 kB in 43s (176 kB/s)                                             
Reading package lists... Done
--2021-10-26 10:38:51--  https://github.com/Philippe734/Simple.NFS.GUI/raw/master/Linux/1.0.16/simple-nfs-gui_1.0.16-0ubuntu1_all.deb
Resolving github.com (github.com)... 192.30.255.112
Connecting to github.com (github.com)|192.30.255.112|:443... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://raw.githubusercontent.com/Philippe734/Simple.NFS.GUI/master/Linux/1.0.16/simple-nfs-gui_1.0.16-0ubuntu1_all.deb [following]
--2021-10-26 10:38:51--  https://raw.githubusercontent.com/Philippe734/Simple.NFS.GUI/master/Linux/1.0.16/simple-nfs-gui_1.0.16-0ubuntu1_all.deb
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 185.199.108.133, 185.199.109.133, 185.199.110.133, ...
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|185.199.108.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 29220 (29K) [application/octet-stream]
Saving to: ‘/home/kim/simple-nfs-gui_1.0.16-0ubuntu1_all.deb’

simple-nfs-gui_1.0. 100%[===================>]  28.54K  --.-KB/s    in 0.002s  

2021-10-26 10:38:51 (13.8 MB/s) - ‘/home/kim/simple-nfs-gui_1.0.16-0ubuntu1_all.deb’ saved [29220/29220]

Selecting previously unselected package simple-nfs-gui.
(Reading database ... 388728 files and directories currently installed.)
Preparing to unpack .../simple-nfs-gui_1.0.16-0ubuntu1_all.deb ...
Unpacking simple-nfs-gui (1.0.16-0ubuntu1) ...
dpkg: dependency problems prevent configuration of simple-nfs-gui:
 simple-nfs-gui depends on gambas3-runtime (>= 3.14); however:
  Package gambas3-runtime is not installed.
 simple-nfs-gui depends on gambas3-runtime (<< 3.99.0); however:
  Package gambas3-runtime is not installed.
 simple-nfs-gui depends on gambas3-gb-form (>= 3.14); however:
  Package gambas3-gb-form is not installed.
 simple-nfs-gui depends on gambas3-gb-form (<< 3.99.0); however:
  Package gambas3-gb-form is not installed.
 simple-nfs-gui depends on gambas3-gb-gtk3 (>= 3.14); however:
  Package gambas3-gb-gtk3 is not installed.
 simple-nfs-gui depends on gambas3-gb-gtk3 (<< 3.99.0); however:
  Package gambas3-gb-gtk3 is not installed.
 simple-nfs-gui depends on gambas3-gb-image (>= 3.14); however:
  Package gambas3-gb-image is not installed.
 simple-nfs-gui depends on gambas3-gb-image (<< 3.99.0); however:
  Package gambas3-gb-image is not installed.

dpkg: error processing package simple-nfs-gui (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24+linuxmint1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Errors were encountered while processing:
 simple-nfs-gui

# Attempting to install the missing library
kim@kim-linux:~$ sudo apt install gambas3-gb-form -y
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 gambas3-gb-form : Depends: gambas3-runtime (>= 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1) but it is not going to be installed
                   Depends: gambas3-gui (>= 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1) but it is not going to be installed
 simple-nfs-gui : Depends: gambas3-runtime (>= 3.14) but it is not going to be installed
                  Depends: gambas3-runtime (< 3.99.0) but it is not going to be installed
                  Depends: gambas3-gb-gtk3 (>= 3.14) but it is not going to be installed
                  Depends: gambas3-gb-gtk3 (< 3.99.0) but it is not going to be installed
                  Depends: gambas3-gb-image (>= 3.14) but it is not going to be installed
                  Depends: gambas3-gb-image (< 3.99.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

# Fix the broken installs
kim@kim-linux:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  gambas3-gb-form gambas3-gb-gtk gambas3-gb-gtk3 gambas3-gb-gtk3-wayland
  gambas3-gb-gtk3-x11 gambas3-gb-image gambas3-gui gambas3-runtime
The following NEW packages will be installed:
  gambas3-gb-form gambas3-gb-gtk gambas3-gb-gtk3 gambas3-gb-gtk3-wayland
  gambas3-gb-gtk3-x11 gambas3-gb-image gambas3-gui gambas3-runtime
0 upgraded, 8 newly installed, 0 to remove and 4 not upgraded.
1 not fully installed or removed.
Need to get 1,190 kB of archives.
After this operation, 4,682 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-runtime amd64 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [522 kB]
Get:2 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-gb-image amd64 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [32.9 kB]
Get:3 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-gb-gtk amd64 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [201 kB]
Get:4 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-gb-gtk3-x11 amd64 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [14.4 kB]
Get:5 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-gb-gtk3-wayland amd64 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [7,884 B]
Get:6 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-gb-gtk3 amd64 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [188 kB]
Get:7 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-gui all 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [6,380 B]
Get:8 http://ppa.launchpad.net/gambas-team/gambas3/ubuntu focal/main amd64 gambas3-gb-form all 3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1 [218 kB]
Fetched 1,190 kB in 1min 22s (14.6 kB/s)                                       
Selecting previously unselected package gambas3-runtime.
(Reading database ... 388744 files and directories currently installed.)
Preparing to unpack .../0-gambas3-runtime_3.16.3+git202109141524.185a3d4a3+build
15~ubuntu20.04.1_amd64.deb ...
Unpacking gambas3-runtime (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.
1) ...
Selecting previously unselected package gambas3-gb-image.
Preparing to unpack .../1-gambas3-gb-image_3.16.3+git202109141524.185a3d4a3+buil
d15~ubuntu20.04.1_amd64.deb ...
Unpacking gambas3-gb-image (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04
.1) ...
Selecting previously unselected package gambas3-gb-gtk.
Preparing to unpack .../2-gambas3-gb-gtk_3.16.3+git202109141524.185a3d4a3+build1
5~ubuntu20.04.1_amd64.deb ...
Unpacking gambas3-gb-gtk (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1
) ...
Selecting previously unselected package gambas3-gb-gtk3-x11.
Preparing to unpack .../3-gambas3-gb-gtk3-x11_3.16.3+git202109141524.185a3d4a3+b
uild15~ubuntu20.04.1_amd64.deb ...
Unpacking gambas3-gb-gtk3-x11 (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20
.04.1) ...
Selecting previously unselected package gambas3-gb-gtk3-wayland.
Preparing to unpack .../4-gambas3-gb-gtk3-wayland_3.16.3+git202109141524.185a3d4
a3+build15~ubuntu20.04.1_amd64.deb ...
Unpacking gambas3-gb-gtk3-wayland (3.16.3+git202109141524.185a3d4a3+build15~ubun
tu20.04.1) ...
Selecting previously unselected package gambas3-gb-gtk3.
Preparing to unpack .../5-gambas3-gb-gtk3_3.16.3+git202109141524.185a3d4a3+build
15~ubuntu20.04.1_amd64.deb ...
Unpacking gambas3-gb-gtk3 (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.
1) ...
Selecting previously unselected package gambas3-gui.
Preparing to unpack .../6-gambas3-gui_3.16.3+git202109141524.185a3d4a3+build15~u
buntu20.04.1_all.deb ...
Unpacking gambas3-gui (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1) .
..
Selecting previously unselected package gambas3-gb-form.
Preparing to unpack .../7-gambas3-gb-form_3.16.3+git202109141524.185a3d4a3+build
15~ubuntu20.04.1_all.deb ...
Unpacking gambas3-gb-form (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.
1) ...
Setting up gambas3-runtime (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04
.1) ...
Setting up gambas3-gb-image (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.0
4.1) ...
Setting up gambas3-gb-gtk (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.
1) ...
Setting up gambas3-gui (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04.1) 
...
Setting up gambas3-gb-form (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04
.1) ...
Setting up gambas3-gb-gtk3-wayland (3.16.3+git202109141524.185a3d4a3+build15~ubu
ntu20.04.1) ...
Setting up gambas3-gb-gtk3 (3.16.3+git202109141524.185a3d4a3+build15~ubuntu20.04
.1) ...
Setting up gambas3-gb-gtk3-x11 (3.16.3+git202109141524.185a3d4a3+build15~ubuntu2
0.04.1) ...
Setting up simple-nfs-gui (1.0.16-0ubuntu1) ...
Processing triggers for shared-mime-info (1.15-1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for man-db (2.9.1-1) ...

# Test triggering the application
kim@kim-linux:~$ sudo -H Simple_NFS_GUI

Screenshots:

Posted on Categories Linux

Leave a Reply

Your email address will not be published. Required fields are marked *