Hyper-V Guest VM CPU Compatibility Feature Down Side

Symptom: guest VM could not install applications that require’SSE4.2 and POPCNT instruction sets’

Cause:

The compatibility feature has been turned on for this guest VM; thus, these CPU features have been disabled:

  • AMD: SSSE3, SSE4.1, SSE4.A, SSE5, POPCNT, LZCNT, Misaligned SSE, AMD 3DNow!, Extended AMD 3DNow!
  • Intel: SSSE3, SSE4.1, SSE4.2, POPCNT, Misaligned SSE, XSAVE, AVX

Resolution:

Disable (uncheck) the ‘allow migration to a virtual machine host with a different processor version’

Leave a Reply

Your email address will not be published. Required fields are marked *